fix install infos + requirements

parent 024cfdb5
...@@ -4,7 +4,7 @@ ...@@ -4,7 +4,7 @@
* Python 3 + headers (ie. python3-dev) * Python 3 + headers (ie. python3-dev)
* virtualenvwrapper * virtualenvwrapper
* PostgreSQL * PostgreSQL (postgresql-server-dev-all)
### Nouvelle Installation ### Nouvelle Installation
...@@ -13,8 +13,8 @@ $ git clone https://git.regardscitoyens.org/regardscitoyens/irfm.git ...@@ -13,8 +13,8 @@ $ git clone https://git.regardscitoyens.org/regardscitoyens/irfm.git
$ cd irfm $ cd irfm
$ mkvirtualenv --python=$(which python3) irfm $ mkvirtualenv --python=$(which python3) irfm
$ pip install -e . $ pip install -e .
$ psql -c "create user irfm with password 'irfm';" $ sudo -u postgres psql -c "create user irfm with password 'irfm';"
$ psql -c "create database irfm with owner irfm;" $ sudo -u postgres psql -c "create database irfm with owner irfm;"
$ irfm db upgrade $ irfm db upgrade
$ irfm import_etapes $ irfm import_etapes
$ irfm import_nd $ irfm import_nd
......
appdirs==1.4.3
beautifulsoup4==4.5.3 beautifulsoup4==4.5.3
dateparser==0.6.0 dateparser==0.6.0
flask==0.12.1 flask==0.12.1
...@@ -7,6 +8,7 @@ flask-migrate==2.0.3 ...@@ -7,6 +8,7 @@ flask-migrate==2.0.3
flask-script==2.0.5 flask-script==2.0.5
flask-sqlalchemy==2.2 flask-sqlalchemy==2.2
nose==1.3.7 nose==1.3.7
packaging==16.8
psycopg2==2.7.1 psycopg2==2.7.1
requests==2.13.0 requests==2.13.0
xhtml2pdf==0.2b1 xhtml2pdf==0.2b1
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment