Commit cd8d01be by Nicolas Joyard

Update readme

parent 2235233a
Showing with 41 additions and 19 deletions
Requirements ParlAPI
- python 2.7 =======
- postgresql 9.2+
L'objectif de ParlAPI est de fournir une API réellement utilisable sur l'Open
Data parlementaire.
Les données proviennent des portails Open Data parlementaires :
* [data.assemblee-nationale.fr](http://data.assemblee-nationale.fr/)
* [data.senat.fr](http://data.senat.fr/)
ParlAPI est conçu de manière à respecter le plus fidèlement possible le schéma
de données des sources parlementaires. En particulier, aucune donnée calculée
n'est ajoutée au modèle.
## Installation
### Prérequis
- Python 2.7
- PostgreSQL 9.2+
- pip
- virtualenv - virtualenv
Installation ### Installation
- git clone
- cd parlapi ```bash
- virtualenv ve $ git clone https://github.com/njoyard/parlapi
- source ve/bin/activate $ cd parlapi
- pip install -e . $ virtualenv ve
- psql -c "create user parlapi with password 'parlapi';" $ source ve/bin/activate
- psql -c "create database parlapi with owner parlapi;" $ pip install -e .
$ psql -c "create user parlapi with password 'parlapi';"
Usage: $ psql -c "create database parlapi with owner parlapi;"
- parlapi createdb ```
- parlapi update_organes_an
- parlapi update_acteurs_an ### Utilisation
- parlapi runserver
- ```bash
\ No newline at end of file $ parlapi createdb
$ parlapi update_organes_an
$ parlapi update_acteurs_an
$ parlapi runserver
```
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or sign in to comment